XDM Website Service Outage

Incident Report for Xirgo Technologies

Resolved

This incident have been resolved.
Posted Jun 09, 2026 - 13:45 EDT

Monitoring

The issue has been identified and fix was released, team continues to monitor.
Posted Jun 09, 2026 - 13:24 EDT

Investigating

We are experiencing intermittent database connectivity issues affecting API requests. Device configuration server and telemetry streaming is not impacted. We continue to investigate the issue.
Posted Jun 09, 2026 - 12:03 EDT
This incident affected: Xirgo Device Management NA (XDM API and UI).